Global AWS Outage Affecting 3rd Party Connections + Performance

Incident Report for Cimplico

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 19:01 AEST

Update

Xero have made an update that technical teams have observed a return of normal services and are monitoring for any remaining impact
Posted Oct 21, 2025 - 15:23 AEST

Monitoring

Some customers are experiencing slowness and issues logging with Xero and utilising Xero integration functionality due to an ongoing global issue with Amazon Web Services (AWS).

You can continue using Cimplico Workpapers, but data updates from Xero may be delayed or error until the issue is fixed upstream.
Posted Oct 21, 2025 - 07:35 AEST
This incident affected: Workpapers and Sync.